Guide Open Source

GUIDE E MANUALI DEL MONDO LINUX E CMS

Guide Open Source

GUIDE E MANUALI DEL MONDO LINUX E CMS

Guide Open Source

GUIDE E MANUALI DEL MONDO LINUX E CMS

Come installare PHP 5.6 (PHP-FPM e FastCGI) con Zend OPcache E APCu Per ISPConfig 3 Su Debian 7 (Wheezy)

Come installare PHP 5.6 (PHP-FPM e FastCGI) con Zend OPcache E APCu Per ISPConfig 3 Su Debian 7 (Wheezy) 2/2

3 Installare PHP 5.6.0 (FastCGI)

Scarica e estrai PHP 5.6.0:

mkdir /opt/phpfcgi-5.6.0
mkdir /usr/local/src/php5-build
cd /usr/local/src/php5-build
wget http://de.php.net/get/php-5.6.0.tar.bz2/from/this/mirror -O php-5.6.0.tar.bz2
tar jxf php-5.6.0.tar.bz2
cd php-5.6.0/

Installare i prerequisiti per PHP5:

apt-get install build-essential
apt-get build-dep php5
apt-get install libfcgi-dev libfcgi0ldbl libjpeg62-dbg libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev
ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a

((È necessario l’ultimo comando se si crea il PHP con –with-imap, perché altrimenti ./configure si fermerà con il seguente errore:

checking for crypt in -lcrypt… yes
configure: error: Cannot find imap library (libc-client.a). Please check your c-client installation.
root@server1:/usr/local/src/php5-build/php-5.6.0#

)

Configurare PHP 5.6.0 come segue (è possibile regolare il comando ./configure secondo le vostre esigenze, vedere

./configure --help

per visualizzare tutte le opzioni disponibili; se si utilizza un comando diverso ./configure, è possibile che siano necessarie librerie aggiuntive, o il processo di compilazione fallirà)

./configure --prefix=/opt/phpfcgi-5.6.0 --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --enable-zip --with-pcre-regex --with-mysql --with-pdo-mysql --with-mysqli --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl --with-fpm-user=www-data --with-fpm-group=www-data --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-imap --with-imap-ssl --with-kerberos --with-gettext --with-xmlrpc --with-xsl --enable-opcache --enable-cgi

L’ultimo switch (–enable-cgi) assicura che questa versione di PHP funzionerà con FastCGI.

make
make install

Copia php.ini nella posizione corretta:

cp /usr/local/src/php5-build/php-5.6.0/php.ini-production /opt/phpfcgi-5.6.0/lib/php.ini

Per abilitare Zend OPcache, aprire /opt/phpfcgi-5.6.0/lib/php.ini

vi /opt/phpfcgi-5.6.0/lib/php.ini

… E aggiungere la seguente riga alla fine:

[...]
zend_extension=opcache.so

Questo è tutto – se vuoi, è possibile installare alcuni moduli aggiuntivi come APCu, memcache, memcached, e ionCube.
Il APCu, memcache, e moduli memcached si possono installare tramite PEAR, prima installiamo e inizializziamo:

apt-get -y install php-pear
cd /opt/phpfcgi-5.6.0/etc
pecl -C ./pear.conf update-channels

APCu ora può essere installato come segue:

pecl -C ./pear.conf install channel://pecl.php.net/apcu-4.0.6

Accetta tutti i valori predefiniti dopodichè apri /opt/phpfcgi-5.6.0/lib/php.ini…

vi /opt/phpfcgi-5.6.0/lib/php.ini

… E aggiungere la linea extension=apcu.so alla fine del file (è possibile anche configurare alcune impostazioni aggiuntive APCu):

[...]
extension=apcu.so
apc.enabled=1
apc.shm_size=128M
apc.ttl=0
apc.gc_ttl=600
apc.enable_cli=1
apc.mmap_file_mask=/tmp/apc.XXXXXX
;apc.mmap_file_mask=/dev/zero
;apc.shm_segments = 5

[slideshow_deploy id=’367′]

Memcache extension può essere installato come segue:

pecl -C ./pear.conf install memcache

Aprire/opt/phpfcgi-5.6.0/lib/php.ini

vi /opt/phpfcgi-5.6.0/lib/php.ini

… aggiungere la linea extension=memcache.so alla fine del file:

[...]
extension=memcache.so

In ISPConfig 3.0.5, è possibile configurare la nuova versione di PHP in System > Additional PHP Versions. Nella scheda Name, basta compilare un nome per la versione di PHP (ad esempio PHP 5.6.0) – questa versione di PHP sarà elencata con questo nome nelle impostazioni del sito in ISPConfig:

1

 

Vai alla scheda Impostazioni di FastCGI (la scheda Impostazioni di PHP-FPM può essere l11asciato vuoto) e compilare i campi come segue:

2

Piaciuto l'articolo? Condividilo sui social!

Share on facebook
Facebook
Share on twitter
Twitter
Share on linkedin
LinkedIn
Share on whatsapp
WhatsApp